happyevdriver
Posts: 2
Joined: Thu Jan 19, 2023 4:24 pm

HELP! car dead when turning off engine

this is 2016 FFE. when turned off the engine, the car was dead immediately, no light on dashboard, remotes did not work. this happened several times recently. I jump started the car and drove it to dealer to check out the battery. battery checked out good by dealer. I drove back and it worked fine for a few days and then it shut off again. now after two days just parking in my driveway , the small 12V battery still read 12.5V so I think the small 12V batter is alright but the car remote won't work. I opened the door using the key and car won't start, no dashboard. if it isn't the battery, what would it be?

Thanks you for your input.
Anti_Climax
Posts: 436
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: HELP! car dead when turning off engine

If it's not the battery, it's the connection to the battery. That's pretty much the only thing that will leave it totally dead.

Check the clamps for tightening and/or corrosion.
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging
happyevdriver
Posts: 2
Joined: Thu Jan 19, 2023 4:24 pm

Re: HELP! car dead when turning off engine

Anti_Climax wrote: Thu Jan 19, 2023 6:25 pm If it's not the battery, it's the connection to the battery. That's pretty much the only thing that will leave it totally dead.

Check the clamps for tightening and/or corrosion.
Thank you for your quick reply. I'll check the battery connections and report back.
triangles
Posts: 1217
Joined: Tue Aug 16, 2011 11:40 am
Location: Toledo, Ohio
Contact: Website

Re: HELP! car dead when turning off engine

Could still be the 12V. Check the voltage with a load on the 12V. But yeah I think Anti_Climax nailed it. Sounds like a bad connection to the 12V battery.
2014 Blue Candy FFE
http://www.fuelly.com/car/ford/focus/2014/triangles/303811 (since this forum doesn't allow BBcode in sigs)

Return to “General / Main Focus Electric Owners Forum”