Anti_Climax
Posts: 324
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: AT&T sunset and MyFordMobile app

Wed Apr 20, 2022 2:05 pm

Got the programming complete this morning. Took a while to actually prompt for activation on each end but it did while I was waiting to get through to a FordPass person. Took a while longer for data to start populating to the app like battery state and it's still not all there (no remote start, lock/unlock, charging doesn't seem to be updating usefully)

They advised it can be 24/48 hours for everything to get into a good state, so now I wait. But so far, LTE on a 2012 with the Sync3 upgrade is a qualified success. No idea if they have extended the availability of the modems in light of the back-order status before, but here's hoping for the sake of others that want to try.
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging

Heima
Posts: 240
Joined: Thu Feb 21, 2019 11:46 pm

Re: AT&T sunset and MyFordMobile app

Wed Apr 20, 2022 10:21 pm

Kool!
Glad you got it working. Gives hope to others who want that functionality, but Ford would not support.

As an aside, do we know for certain whether or not a Sync 3.0 unit updated to Sync 3.4 will work with the 4G modem?

Thanks

Anti_Climax
Posts: 324
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: AT&T sunset and MyFordMobile app

Thu Apr 21, 2022 8:47 pm

I honestly don't know - I'll check my SYNC unit version, don't know it off the top of my head.

Most of it still isn't working. I get location for the car and battery level, but no charge details, no remote lock/unlock or start. Still in the 48 hours though. I'll give them a call if it hasn't started working by tomorrow afternoon.

Anyone with a newer focus able to share the AsBuilt config for their TCU?
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging

cr08
Posts: 13
Joined: Tue Oct 09, 2018 8:11 pm

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 3:38 pm

Been lurking this thread for a hot minute. I'm a C-Max owner myself, but can confirm Sync 3.4.x functions just fine with the new 4G TCU's. Mine's a 2013 (with a Sync 3 retrofit) which wasn't on the official upgrade CSP and shares a similar electrical architecture to the Focus so wouldn't surprise me that all would work fine with these early model years for you guys as well. Most of the issues seen so far are just Ford getting their backend/the FordPass app updated to work with the 'new' xEV functions that it never had before. Most functions seem to be working now thankfully.

Additionally, DIY'ing these upgrades is also possible and quite painless as long as you can find the appropriate TCU. We've documented a lot of the process over in the linked thread below:

https://fordcmaxhybridforum.com/topic/1 ... em-update/

Right now it seems only a limited set of 'used' TCU's are compatible in the following part #'s: 'HJ5T-14G087-**'. Those of us who have DIY'd this so far all seem to have gotten ours from 2017 Escape Titanium's. The official upgraded modems appear to just be these same parts just refurbished and an updated calibration. We've found the used ones will take the same updated calibration which is needed to enable the Go Time/Value Charge features.

Anti_Climax
Posts: 324
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 3:42 pm

My Sync is 3.0

At this point almost none of it works, let alone the EV specific stuff like Go Times. I can't even remote lock/unlock. :(

That is to say, the options display on the app - they simply fail when I try to use them.
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging

cr08
Posts: 13
Joined: Tue Oct 09, 2018 8:11 pm

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 3:54 pm

Anti_Climax wrote:
Fri Apr 22, 2022 3:42 pm
My Sync is 3.0

At this point almost none of it works, let alone the EV specific stuff like Go Times. I can't even remote lock/unlock. :(
If you have access to ForScan and an appropriate OBD adapter, can you retrieve the AsBuilt from your TCU and post it? Might also be worth confirming what calibration it notes is on the TCU.

We've seen quite a number of cases where it seems the dealers miss a step or two and the likely culprit for none of those features working is a misconfigured AsBuilt. If this is the case, it is a super easy and quick fix.

Regarding what should be seen in the AsBuilt config and this should be tailored towards the Focus Electric:

754-01-01: B742-xx (B for Sync 3. Change to A if you are still on Sync 2)
754-02-01 1EA0-xx (some have had 00A0 here as well at least on the C-Max. Doesn't seem to make a functional difference. Nothing in these bits should change for the FE either)
754-03-01 -through- 754-03-08 all bits should be 7D so it should be a repeating 7D7D all the way. ForScan shows the checksum bits which are the last two bits on each block. These will never be 7D. Ignore them.
EXCEPTION to the above line: 754-03-06 should be set to 0078-7D7D-7D.

All of this has documentation on what each bit does on the CyanLabs AsBuilt page: https://cyanlabs.net/asbuilt-db/tcu-h-database/

Anti_Climax
Posts: 324
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 8:09 pm

This is what they put in. I already changed the A to B at the suggestion of the man that sold me the upgrade.

Code: Select all

;Block 1 754G1G1A78286 ;Block 2 754G2G100A0FE ;Block 3 754G3G17D7D7D7D7DD0 754G3G27D7D7D7D7DD1 754G3G37D7D7D7D7DD2 754G3G47D7D7D7D7DD3 754G3G57D7D7D7D7DD4 754G3G600787D7D7D53 754G3G77D7D7D7D7DD6 754G3G87D7D60 ;Block 4 754G5G1000000781EF7 754G5G20277DB
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging

cr08
Posts: 13
Joined: Tue Oct 09, 2018 8:11 pm

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 8:35 pm

Anti_Climax wrote:
Fri Apr 22, 2022 8:09 pm
This is what they put in. I already changed the A to B at the suggestion of the man that sold me the upgrade.

Code: Select all

;Block 1 754G1G1A78286 ;Block 2 754G2G100A0FE ;Block 3 754G3G17D7D7D7D7DD0 754G3G27D7D7D7D7DD1 754G3G37D7D7D7D7DD2 754G3G47D7D7D7D7DD3 754G3G57D7D7D7D7DD4 754G3G600787D7D7D53 754G3G77D7D7D7D7DD6 754G3G87D7D60 ;Block 4 754G5G1000000781EF7 754G5G20277DB
You have 754-01-01 set for B782. Try changing to B742. The last two bits cover the vehicle electrical architecture. In this case 82 is setting it for C1MCA which I don't think is compatible with the Focus. We've had users report the same trying that on the C-Max. 42 sets it for CGEA 1.2 which should be compatible. Very likely this alone will solve all your issues as this specifically controls how it communicates with the vehicle. Everything else you posted looks correct.

Anti_Climax
Posts: 324
Joined: Fri May 20, 2016 12:22 pm
Location: The Valley of the Sun

Re: AT&T sunset and MyFordMobile app

Fri Apr 22, 2022 9:55 pm

I could kiss you.

Adding the car to the app again, it showed a tile for achievements that was not visible before.

Remote start/stop is working. Lock/Unlock are working, charge status seems to be updating better than it was but still not all the way there. Charge level notifications still don't seem to set (but wasn't that something that they know doesn't work for Focus EV yet?). Go times updated to SYNC though the app said they were failing to set. Another attempt showed them in the app.

My test trip actually logged to the EV driving log. The battery percentage was updating to the app fairly regularly during. The charge session still isn't filling out - I plugged in at about 91% SoC. It estimates I'll finish charging at 12:14AM on Tuesday February 15th (pretty sure that was my last L1 charge before pulling my old TCU and SYNC has been master reset a few times since. Not sure what's going on there)

I'm probably going to call and cancel the escalation and give this the weekend to "settle in" before I re-asses.

Thank you again, very much, for sharing this info.

EDIT: It really looks like it's just the charging data not getting through. Energy used also didn't populate to my logged trip - so it seems like something specific to that energy tracking aspect. Any ideas? Anyone have the AsBuilt for an official FFE TCU upgrade?
2012 Candy Blue FFE
33.5kWh battery pack
CHAdeMO DC Fast Charging

cr08
Posts: 13
Joined: Tue Oct 09, 2018 8:11 pm

Re: AT&T sunset and MyFordMobile app

Sat Apr 23, 2022 8:44 am

Anti_Climax wrote:
Fri Apr 22, 2022 9:55 pm
I could kiss you.

Adding the car to the app again, it showed a tile for achievements that was not visible before.

Remote start/stop is working. Lock/Unlock are working, charge status seems to be updating better than it was but still not all the way there. Charge level notifications still don't seem to set (but wasn't that something that they know doesn't work for Focus EV yet?). Go times updated to SYNC though the app said they were failing to set. Another attempt showed them in the app.

My test trip actually logged to the EV driving log. The battery percentage was updating to the app fairly regularly during. The charge session still isn't filling out - I plugged in at about 91% SoC. It estimates I'll finish charging at 12:14AM on Tuesday February 15th (pretty sure that was my last L1 charge before pulling my old TCU and SYNC has been master reset a few times since. Not sure what's going on there)

I'm probably going to call and cancel the escalation and give this the weekend to "settle in" before I re-asses.

Thank you again, very much, for sharing this info.

EDIT: It really looks like it's just the charging data not getting through. Energy used also didn't populate to my logged trip - so it seems like something specific to that energy tracking aspect. Any ideas? Anyone have the AsBuilt for an official FFE TCU upgrade?
Glad that got it working for you!

You should be all good to go now. There are no further changes you can make to the AsBuilt to improve things. Now it's up to Ford to start populating this stuff in FordPass on their end. Your car is sending the proper information.

All those '7D' bits I mentioned earlier are various data collection bits, 7D basically telling it to collect and report this information to Ford. All of those are set to do this so it's sending everything that's available. Likewise, the TCU already knows you have an electric only vehicle and the relevant parameters from that due to the 754-01-01 line set to B742 with the 7 specifically to indicate this.

I can tell you at least on my C-Max, one of the last remaining features not showing yet is the 'My EV Driving Data' feature under the Journeys tile in FordPass. This is where specifics about the trip and EV usage -should- be but nothing there yet and doesn't seem like it's functional yet for anyone else. Again, this is likely all going to be down to waiting on Ford to update things on their end and nothing that can be done for you as an owner and no further tweaking of the TCU is going to fix it. We've seen a lot of functions in the app come and go over the past month or so with no changes to our TCU's as Ford continues to work on this stuff.

There is a brand new calibration out for these now, though no clue what changes there are and if it will make much of a difference here. But I'm going to be doing that update on my C-Max and will definitely report if it makes any meaningful improvements or changes.

Return to “Technical Discussions”