disar
Posts: 2
Joined: Mon Jul 04, 2022 12:41 pm

FFE turn OFF while breaking

Mon Jul 04, 2022 1:23 pm

Hi!
I have problem with my FFE 2014. When I operate accelerator pedal everything is ok, but when I stop operating car goes into service mode and turn off. I need to restart it by pressing start button.
Errors which I read from Forscan:
P0AFB Code - Battery System Voltage High
P0C07 Code - Drive Motor 'A' Phase U-V-W Circuit High
P0C05 Code - Drive Motor 'A' Phase U-V-W Circuit/Open

Sometimes I had errors with stucking "plus"contactor

I replaced TCM for used one, but it didnt solve my problem. After few test rides I have new problem - car doesnt start and I have error:
P0AF8 Code - Hybrid Battery System Voltage (too low)

Do you have any ideas what should I check now?

Where is + and - contactors? Both are at upper battery pack?

Heima
Posts: 245
Joined: Thu Feb 21, 2019 11:46 pm

Re: FFE turn OFF while breaking

Mon Jul 04, 2022 9:45 pm

Wow, I have never seen those codes before:
So I guess you know that P0c07 and P0c05 deal with the TCM. Yet you replaced that. Did you replace the entire drive unit or just the box on top of the inverter?
I would check the continunity of the separate phases of the motor between the inverter, to make sure that nothing is open. Likewise, check if there are any fuses in the TCM or inverter that have blown.
The P0AFB and P0AF8 are supposedly also in the TCM. The P0AFB is a greater than 390V situation (don't know how that would happen) unless from regen braking going nuts, and the P0AF8 is a less than 190V situation. If the battery was dead.
Since these are also TCM codes, I am thinking that something is wrong with the TCM you just installed, or perhaps what the TCM connects to.
Yes, the contactors are in the upper battery. There might be two in the lower battery as well. Cannot remember.
The service manual says to replace the entire drive unit, so it can't help you with the inverter/TCM replacement.

Watch this video for visualization:
https://www.youtube.com/watch?v=ML6ucMDWS2c

disar
Posts: 2
Joined: Mon Jul 04, 2022 12:41 pm

Re: FFE turn OFF while breaking

Wed Jul 06, 2022 11:51 am

I just replaced inverter box on top of the motor (took motor out of the car). Errors are the same with both inverters, so I think that inverter is not a problem. I checked motor phases (with standard multimeter 'resistance' ) and I didn't found any problem. Isolation has infinity resistance.

The biggest problem with TCM is that it's one of PATS system. It's very difficult to code used one.

P0AFB is active while regen braking. I check voltage at TCM while braking and it goes sometimes above 400V for less than 1s. At the same time I checked voltage in BCM and there is no problem (~360V). When I drive without braking everything is OK :shock:

I checked voltage at upper battery (before contactors) and I have ~160V. So maby P0AF8 is active becouse one of lower contactor is bad?

I think my next step will be motor replace :roll:

Return to “Technical Discussions”