An online Ford Focus Electric Forum discussion group

It is currently Tue Oct 23, 2018 1:56 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Jun 08, 2018 1:41 pm 
Offline

Joined: Thu Jun 23, 2016 12:21 pm
Posts: 33
So my daugther tells me that the touchscreen quit working in her 2013 FFE. When I finally get in the car, the touchscreen is fine, but the radio will not play. The phone connects in bluetooth, but no sound. Then, I realize that the entire radio is dead. Touchscreen is fine, but the power, volume, source, etc... is dead. I thought.... good, much better than the touchscreen going bad. I pop the hood, and figure I will start with the fuse. There are numbered fuses and relays in the box under the hood, but no labels. There is also some smoky dust under the cover of the fusebox, so that's not good, but it is a clue. I did some googling looking for the radio fuse, and have been unsuccessful in finding which one it is. What is the ford parlance for the head unit ? "RADIO" or "ENTERTAINMENT UNIT" ??

Anyone been there/done that ?

I am hoping that someone in the car was playing it too loud and popped a fuse, but that seems real unrealistic. No other electric features are inoperable, as far as I can tell, like the door locks work, etc... I am expecting that there is a second fuse box somewhere, but the one under the hood has evidence of a burned fuse or relay. I didn't want to have to begin by pulling all of them, one at a time.

TIA,
Richard


Top
 Profile  
 
PostPosted: Fri Jun 08, 2018 1:46 pm 
Offline

Joined: Thu Jun 23, 2016 12:21 pm
Posts: 33
I searched before I posted, and found nothing. Right after I hit post, I found this thread:

viewtopic.php?f=14&t=2335

Should prove helpful, I think.


Top
 Profile  
 
PostPosted: Sat Jun 09, 2018 2:43 am 
Offline

Joined: Tue Feb 12, 2013 4:36 am
Posts: 2328
Location: Southeastern MI
Pull the fuse in the fusebox behind the glovebox--forget which one but its listed in the owner's manual.

_________________
2018 Cajun Red Chevy Bolt
2016 Magnetic C-Max Energi
2014 Sunset Escape
2014 Thor Axis (V-10)
2013 Focus Electric (lease returned Jan 2016 for the C-Max above)
https://spareelectrons.wordpress.com/


Top
 Profile  
 
PostPosted: Tue Jun 12, 2018 7:44 pm 
Offline

Joined: Tue Nov 29, 2016 7:02 pm
Posts: 40
Our 2013's display started to lose abilities and hade to be re-booted a lot. Finally one day the car wouldn't run at all. The 12v auxiliary battery was dead. Replaced the battery and all is well. I then read that a wonkly display is a sign the battery is on the way out the door. Worth checking yours if the other solutions don't help, especially if you still have the original battery.


Top
 Profile  
 
PostPosted: Fri Jun 15, 2018 12:26 pm 
Offline

Joined: Thu Jun 23, 2016 12:21 pm
Posts: 33
pulling the fuse for the radio, fuses 79 and 81 worked ! I cant saw which, as I pulled, then reseated them both. Cool


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 8 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
© Ford Focus Electric Forum - part of the MyElectricCarForums.com Group