An online Ford Focus Electric Forum discussion group

It is currently Tue Jun 27, 2017 12:37 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Sun Feb 12, 2017 11:00 am 
Offline

Joined: Tue Apr 26, 2016 9:16 pm
Posts: 7
My nephew's light ring replaced twice. I think it was done under warranty.
He drives 2012 ffe.
I have had no problems with mine. 2013 lease return. Had for almost a year.
Great car. No problems.


Top
 Profile  
 
PostPosted: Sun Feb 12, 2017 10:59 pm 
Offline

Joined: Sat Nov 26, 2016 8:53 am
Posts: 18
Unfortunately I have no where to replace it in Ukraine .
Official Ford service here looking on FFE like on UFO... They have no parts for this vehicle.


Top
 Profile  
 
PostPosted: Mon Feb 13, 2017 9:33 am 
Offline

Joined: Tue Aug 06, 2013 9:10 pm
Posts: 753
Location: Chicago Area
darkball wrote:
Unfortunately I have no where to replace it in Ukraine .
Official Ford service here looking on FFE like on UFO... They have no parts for this vehicle.

That's rough. My geography needed a little refresher. You are in the middle of ---- well not a lot of Western European countries around you.

I am pretty sure they sold the FFE in France and Germany. But wow, those are a million miles from you. Parts will be tough for you.

_________________
2014 Platinum White FFE (Turning in mid Dec. 2016 25,000 miles)
2013 Ingot Silver FFE
2012 Titanium ICE Focus
2014 Tesla Model S 85


Top
 Profile  
 
PostPosted: Fri Jun 16, 2017 10:43 am 
Offline

Joined: Tue Apr 21, 2015 10:38 pm
Posts: 14
I have a 2013 FFE with 22k miles. Light ring is going out. Dealer wants $800 to replace it.

Seems like and very expensive part that more than a few people are having a problem.


Top
 Profile  
 
PostPosted: Fri Jun 16, 2017 2:53 pm 
Offline

Joined: Sat Jan 07, 2017 3:50 pm
Posts: 40
Location: Orlando, FL
I recently had mine replaced, successfully. However now with the rain we've been having, I've noticed it's filling with water. Has anyone else had that problem?

_________________
'13 FFE 25,000 Miles w/15.9 Kwh left


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2

All times are UTC - 8 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
cron
© Ford Focus Electric Forum - part of the MyElectricCarForums.com Group