stargazer
Posts: 12
Joined: Mon Feb 20, 2017 6:44 pm

2013 FFE with MyFordTouch 3.1.3

Fri Mar 24, 2017 2:47 pm

I have a 2013 FFE with MFT 3.1.3 and have been trying to upgrade the software to 3.5.1 or better. I've managed to find several packages still offered up on ford web locations, only to find that they will not upgrade my really old version. Does anyone who had 3.1.3 still have the .zip or .exe file from when they updated their car? If so, would anyone be willing to share?

I know that it's out there, I just need to find it. I've checked another VIN of a car up for sale in my area and it's a 2013 running version 3.5. Unfortunately the dealer selling it is an independent dealer and likely knows absolutely nothing about Ford's vehicles, much less any other vehicle on their lot.

Thanks,

jmueller065
Posts: 2377
Joined: Tue Feb 12, 2013 4:36 am
Location: Southeastern MI
Contact: Website

Re: 2013 FFE with MyFordTouch 3.1.3

Fri Mar 24, 2017 5:17 pm

You could always just take it to a Ford dealer: The upgrade is free (if the Ford dealer tries to charge you something just walk away and find another).
2018 Cajun Red Chevy Bolt
2016 Magnetic C-Max Energi (lease returned)
2014 Sunset Escape
2014 Thor Axis (V-10)
2013 Focus Electric (lease returned Jan 2016 for the C-Max above)
https://spareelectrons.wordpress.com/

WattsUp
Posts: 2113
Joined: Mon Jan 07, 2013 2:58 am
Location: SF Bay Area, CA

Re: 2013 FFE with MyFordTouch 3.1.3

Fri Mar 24, 2017 9:29 pm

I can't remember exactly, but I think somewhere along the way a hardware upgrade was required in order to move to a certain later version of MFT.

I think it was 3.6.x or so that would not install unless you also had the updated hardware. At the time, the updated hardware was free via a recall. (Maybe it still is?) But, you had to go to the dealer.

After that, I believe I updated myself to some later version, 3.8.x or so, via USB stick after downloading the files from the Ford website.
2013 FFE, Platinum White, Delivered January 2013
2017 MS, Midnight Silver Metallic, Delivered February 2017
Use my referral code (http://ts.la/matt4377) to save $1000 on your next Tesla AND get free unlimited Supercharging!

Pearl
Posts: 278
Joined: Wed Apr 13, 2016 3:24 am
Location: Northeast Ohio

Re: 2013 FFE with MyFordTouch 3.1.3

Mon Mar 27, 2017 5:16 am

When I had 3.1.3, I was unable to upgrade myself via USB. I took it into the dealer, and they had one hell of a time updating. IIRC, they had to swap out my APIM. Running 3.8 ever since, no issues.
2013 Focus Electric
2013 C-Max Energi
2013 Escape

stargazer
Posts: 12
Joined: Mon Feb 20, 2017 6:44 pm

Re: 2013 FFE with MyFordTouch 3.1.3

Mon Mar 27, 2017 8:52 am

I took it to the dealer and they "loaded" an update, but when i got it back, it still showed the old version 4.27.12058 a.k.a. 3.1.3. Mine has the warranty extension 12M02 for the APIM, but we haven't really explored that due to the fact the unit is still functioning. They won't replace it under 12M02 unless it's dead or throwing a code.

Took it back today and spoke with the technician. He seemed genuinely interested in fixing it (which is a refreshing change, btw) and when we looked up the TSB on his computer, we found a flow chart that basically asked "What is the last 5 digits of the CCPU version?", and if it's not 15128 (a.k.a. 3.8), apply the update. He seemed genuinely surprised when I showed him it was 12058 (a.k.a. 3.1.3). So once that happened, he realized that there was something not right, admitted that Fords can be hard to update sometimes, and asked me to bring it in.

Of course I agreed, knowing full well that the road to getting the Sync/MFT updated on this thing might be tough. But if I'm going to keep this thing for the foreseeable future, I want it working right, or at least as "right" as Generation 2 Sync can be...

Thanks for the feed back, all!

stargazer
Posts: 12
Joined: Mon Feb 20, 2017 6:44 pm

Re: 2013 FFE with MyFordTouch 3.1.3

Wed Mar 29, 2017 7:13 pm

Well, I took it back to the dealer today. They had it all day. They were still not able to get the software updated. And on top of it, the navigation is now gone.

{sigh}

I should have left well enough alone.

It qualifies for the 12M02 warranty extension on the APIM. Anybody have any good ideas on how I can convince the service adviser to replace the APIM when the only issues present are occasional crashes, bad bluetooth performance, and failure of the display to show what's being played when my iPhone is connected via Bluetooth?

jjsv1
Posts: 50
Joined: Sat Jan 07, 2017 3:50 pm
Location: Orlando, FL

Re: 2013 FFE with MyFordTouch 3.1.3

Thu Mar 30, 2017 2:59 am

This sounds exactly like what happened to me. It took 3 visits. I ended up calling the vehicle technology team that gave me a case number and told the dealer to call them. It took a week, but after they finally replaced the APIM, the car updated. Which gave me the power flow and go times feature on the radio I didn't have.
'13 FFE 36,000 Miles w/15 Kwh left

Pearl
Posts: 278
Joined: Wed Apr 13, 2016 3:24 am
Location: Northeast Ohio

Re: 2013 FFE with MyFordTouch 3.1.3

Thu Mar 30, 2017 4:59 am

Get in touch with the FordIVTteam over at fordsyncforum. They can help escalate the issue.
http://fordsyncforum.com/index.php?/use ... rdivtteam/
2013 Focus Electric
2013 C-Max Energi
2013 Escape

stargazer
Posts: 12
Joined: Mon Feb 20, 2017 6:44 pm

Re: 2013 FFE with MyFordTouch 3.1.3

Wed Apr 05, 2017 2:58 pm

OK, so trip #3 to the dealer (they had it all day) is a bust. Nothing done. They are still trying to prove something to Ford so they can replace the APIM under 12M02. I did sign up on syncforums.com and posted info there.

So we'll try this again next week when I have availability again. :roll:

stargazer
Posts: 12
Joined: Mon Feb 20, 2017 6:44 pm

Re: 2013 FFE with MyFordTouch 3.1.3

Thu Apr 20, 2017 9:40 am

Trip #4: Took the car in yesterday. They had it all day and I just got it back this morning. They fixed the Navigation, but it still shows the old version of code.

The tech claims the proper version of code is loaded, but that the display in the car is not showing the proper version number.

I don't see a "leaf" icon at the bottom of the display, which to my knowledge is a dead giveaway that something newer than 3.1.3 is loaded.

I've had no response from anyone on the Sync forums from the IVT team. I guess my next move is to call Ford, but I'm not looking forward to that.

I can be happy, or I can be right. I'm leaning towards happy with what I've got, even if it's not right.

Return to “Technical Discussions”