WindPowered
Posts: 80
Joined: Thu Mar 28, 2013 10:51 am

Re: Radio Won't Shut Off

Mon May 13, 2013 8:33 am

Fluke wrote:For clarification, I did multiple shutdown/startup cycles to try and get the radio to shutoff.

...

The only thing that would shut mine off was pulling the fuse.
Yeah, I came to the same conclusion albeit with less comprehensive effort (i.e. possibly prematurely). I turned the car on/off 3 times. Open closed driver/passenger doors. Tried just "accessory mode" (vs regular starting).

But still nothing on the radio responded to input; not volume, channel change or power. The center console infotainment screen would let me choose a different preset frequency (I was listening to the radio) and it indicated the channel changed, but the radio didn't actually change.

Oddly enough, after pulling the fuse, replacing it and starting the car, the radio immediately came back on, but the infotainment system (through the right steering wheel control pad) indicated the radio was turned off. I had to cycle through a power on/off for it to get sync'd back up with the actual state of the radio and functioning properly again.

Obviously there's a bug somewhere in the radio / MyFordTouch interface that's causing this hung state.


WP

sl4vik
Posts: 7
Joined: Tue Mar 26, 2013 11:14 am

Re: Radio Won't Shut Off

Mon May 13, 2013 8:57 am

I have the opposite problem, my wont turn on. Reset did nothing, its going in for service today. 2 months in and already radio dead. Great Ford quality..

chaynes
Posts: 1
Joined: Fri May 25, 2018 11:39 am

Re: Radio Won't Shut Off

Fri May 25, 2018 12:37 pm

System reset, etc didn't help me with this problem. Dealer wanted me to bring it in, in 5 days. I argued that wasn't acceptable with a loud radio playing, and said it looked very much like a glitch that a computer reboot would fix. They said I could disconnect the negative battery terminal, which would at least stop the radio, and also reboot when reconnected. That fixed the problem.

Return to “General / Main Focus Electric Owners Forum”