Search found 57 matches

Go to advanced search

by GHTech
Sat Sep 09, 2017 5:00 pm
Forum: Technical Discussions
Topic: Focus EV Shows "Check Battery Charge"
Replies: 10
Views: 8013

Focus EV Shows "Check Battery Charge"

Hi!   I have a 2016 Ford Focus EV that has 7,500 miles on it. Recently after charging the car, the first time I started the car I got the red battery with a "Check Battery Charge" message. After I got to my destination and turned off the car, and restarted it, the message was gone. This has happened...
by GHTech
Wed Jul 05, 2017 8:31 am
Forum: Buying / Leasing / Dealerships
Topic: How Is This Lease?
Replies: 9
Views: 8287

Re: How Is This Lease?

Hi!

Just for reference, below is a summery of my numbers.

Location: So. Cal
Model: 2016 FFE Leather
Down Payment: $0
Term: 3 years
Mileage: 10,500 per year
Monthly: $225
Date: end of Apr 2016

Regards,

Emil
by GHTech
Wed Jan 11, 2017 3:15 pm
Forum: General / Main Focus Electric Owners Forum
Topic: Vehicle Health Report
Replies: 3
Views: 3238

Vehicle Health Report

Greetings!

I have a 2016 FFE, and was told that the Vehicle Health Report is not an option. Is that info correct?

Thanks,

GHTech
by GHTech
Tue Jan 10, 2017 2:51 pm
Forum: Technical Discussions
Topic: Unofficial Sync3 v2.2 Update for 2016s (Carplay/AA)
Replies: 35
Views: 27211

Re: Unofficial Sync3 v2.2 Update for 2016s (Carplay/AA)

Hi!

Just did the update, and it went fine. I have not messed with it much. This was on a 2016 FFE.

Regards,

GHTech
by GHTech
Sun Dec 25, 2016 1:32 pm
Forum: Technical Discussions
Topic: Problem Moving from a Stop
Replies: 28
Views: 24256

Re: Problem Moving from a Stop

Hi! Thank you for the suggestions, and that makes a lot of sense for my 3rd occurrence of this issue, as I was parked in a parking spot and was starting the car to move out. and was most likely in a hurry to move. I will follow the recommendations. The problem is that in the 1st and 2nd occurrences ...
by GHTech
Fri Dec 23, 2016 12:56 pm
Forum: Technical Discussions
Topic: Problem Moving from a Stop
Replies: 28
Views: 24256

Re: Problem Moving from a Stop

What exactly did you try a few times? Hi WattsUp! Tried putting it back into Park, and turning the car off. Started back up, tried moving forward and backwards, no go. Turned it off, and put the parking brake on. Tried this combination a few times. After a little while I turned off the automatic he...
by GHTech
Fri Dec 23, 2016 12:34 pm
Forum: Technical Discussions
Topic: Problem Moving from a Stop
Replies: 28
Views: 24256

Re: Problem Moving from a Stop

Hi! Problem showed up again. Green car was on, and the 2016 FFE would not move forward or backwards. I was in a parking lot that is flat. Tried it a few times, and then after about 5 minutes, the car moved. I did turn off the automatic headlights and radio off after trying a few times. Suggestions? ...
by GHTech
Tue Dec 13, 2016 6:11 am
Forum: General / Main Focus Electric Owners Forum
Topic: New Recall - Differential Assembly
Replies: 79
Views: 50475

Re: New Recall - Differential Assembly

In my case the car had reversed out of the parking spot, and when switched to Drive, it did not move. Tried moving it between D and R, and then P and turned car off. Turned it back on (made sure that the Green Car was on), and put into Drive, and the car did not move. After a few different tries, t...
by GHTech
Mon Dec 12, 2016 10:01 pm
Forum: General / Main Focus Electric Owners Forum
Topic: New Recall - Differential Assembly
Replies: 79
Views: 50475

Re: New Recall - Differential Assembly

About confused starting - honestly, the car isn't confused. This comes up with new owners pretty often. You just have to get used to the routine and timing. Get in the car, press and hold the brake pedal down, press the start button, release the brake pedal, put on your seat belt, and the car will ...
by GHTech
Mon Dec 12, 2016 10:52 am
Forum: General / Main Focus Electric Owners Forum
Topic: New Recall - Differential Assembly
Replies: 79
Views: 50475

Re: New Recall - Differential Assembly

your have a 2016FFE ? only a few hundred cars were affected (mine being one) I doubt it has anything to do with your issue, I had these both on my 2016 and 2013 and it was more about the car being confused and not energizing the motor Yes, it is a 2016. Curious to know about why the 2014 was replac...

Go to advanced search