Search found 3 matches

Go to advanced search

by oneidwally
Sat Mar 28, 2020 11:24 am
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 4674

Re: My 2013 FFE has been in shop for 1 month with Bad ECM

I'm looking at a similar situation. Mine's been in the dealer service bay for 2+ months, and they are laying off a lot of their staff. The update I got this week was that Ford is also cutting back their technical staff. So not only is the dealer understaffed and slower, the engineers at Ford are als...
by oneidwally
Wed Mar 11, 2020 5:12 pm
Forum: Batteries and Charging Forum
Topic: FFE 2013 now at dealer for 7 weeks for battery tests
Replies: 1
Views: 3679

Re: FFE 2013 now at dealer for 7 weeks for battery tests

An update - after pressuring the service representative at the Ford dealer for a timeline, he said 3 more weeks. So it sounds like my care will be on part with the 2-3 months that most everyone else is experiencing. On the plus side, if they do put in a new battery, I hear that Carvana will pay a ve...
by oneidwally
Fri Mar 06, 2020 8:21 pm
Forum: Batteries and Charging Forum
Topic: FFE 2013 now at dealer for 7 weeks for battery tests
Replies: 1
Views: 3679

FFE 2013 now at dealer for 7 weeks for battery tests

Hi everyone - thanks for all the great info and help on this forum! I have a 2013 FFE that recently started having the wrench light turn on. I took it to a dealer to do all the warranty repairs and to figure out what was causing the service light. The've now had the vehicle going on 2 months, and th...

Go to advanced search