Search found 5 matches

Go to advanced search

by Lahiiem
Fri Mar 27, 2020 6:54 pm
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 11633

Re: My 2013 FFE has been in shop for 1 month with Bad ECM

So after I originally thought I would have my car back. Guess what? Still in the shop. What is today's date? 27th of March. This is Nuts. I know the world is crazy with the Virus and such but to get a call yesterday telling me come pick up my car. I was very happy just to have a work car. Sharing on...
by Lahiiem
Thu Mar 05, 2020 6:05 pm
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 11633

Re: My 2013 FFE has been in shop for 1 month with Bad ECM

Just an update incase anyone else come upon this issue. After dealing with my shitty ford dealer. They finally got ford engineering to fly over and look over the car after being in the shop for 3 months. Ford decide it was the battery and will foot the cost of replacement. I'm not sure if I'm gettin...
by Lahiiem
Sat Feb 01, 2020 10:42 am
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 11633

Re: My 2013 FFE has been in shop for 1 month with Bad ECM

:lol: Lahiiem , I can help you Do you have a desire to repair your car yourself? I just got a phone call from ford. Mechanics warranty will foot the bill for parts after having a letter from an attorney sent to them. Pretty sad because they must know they're in the wrong from the start. Ill end up p...
by Lahiiem
Sun Jan 26, 2020 3:28 am
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 11633

Re: My 2013 FFE has been in shop for 1 month with Bad ECM

It's from a 3rd party called The Mechanics.
by Lahiiem
Wed Jan 22, 2020 7:19 am
Forum: General / Main Focus Electric Owners Forum
Topic: My 2013 FFE has been in shop for 1 month with Bad ECM
Replies: 10
Views: 11633

My 2013 FFE has been in shop for 1 month with Bad ECM

1st, I would like to say greeting to everyone and sorry I had to come here asking for help or ranting. I have a 2013 FFE with roughly 68k miles. I ran into a Stop Safely Now code. I had for a few days before it wasn't able to clear in it's own. Towed it to Ford dealer where it sat for a month. I fin...

Go to advanced search