Search found 10 matches

Go to advanced search

by mdfocus
Thu Jul 04, 2019 7:58 am
Forum: General / Main Focus Electric Owners Forum
Topic: Battery overheating? during drive and charging
Replies: 7
Views: 1265

Re: Battery overheating? during drive and charging

Check coolant level.
Have dealer do a coolant system purge. Ask them to do it twice. This will get rid of any air trapped in system and if one of the coolant valve are not working it should show up while they are doing the procedure.

Hope this helps.
by mdfocus
Fri Jun 07, 2019 6:12 am
Forum: Technical Discussions
Topic: Stop Safely Now Warning
Replies: 693
Views: 259540

Re: Stop Safely Now Warning

Call dealer back. Have them check 8 year 100k mile coverage on electric power train.
by mdfocus
Fri Feb 15, 2019 1:12 pm
Forum: Technical Discussions
Topic: Auto door handle sensor not working
Replies: 8
Views: 2255

Re: Auto door handle sensor not working

Try changing battery again. Use a brand name battery like Eveready or Duracell. Have had no name ones not work new from the store.

2013 ffe
2013 c-max
by mdfocus
Tue Aug 07, 2018 6:35 pm
Forum: Buying / Leasing / Dealerships
Topic: Help, Focus electric won't start after 2 weeks - my options?
Replies: 1
Views: 2152

Re: Help, Focus electric won't start after 2 weeks - my opti

I think you might be posting in the wrong topic.
Do you know why it is not starting?
Has anyone done a diagnostic scan on the car?
by mdfocus
Sun Feb 12, 2017 11:00 am
Forum: General / Main Focus Electric Owners Forum
Topic: I have strange issue with my Charging Port Light Ring
Replies: 14
Views: 6884

Re: I have strange issue with my Charging Port Light Ring

My nephew's light ring replaced twice. I think it was done under warranty.
He drives 2012 ffe.
I have had no problems with mine. 2013 lease return. Had for almost a year.
Great car. No problems.
by mdfocus
Sun Jan 08, 2017 7:55 pm
Forum: Technical Discussions
Topic: Problem Moving from a Stop
Replies: 28
Views: 21609

Re: Problem Moving from a Stop

I once had to start the car with the moble app. Then pushed the start button in car with my foot on brake. Thankfully this was in my driveway.

2013 ffe lease return
by mdfocus
Sat Dec 31, 2016 11:15 am
Forum: Technical Discussions
Topic: No heat.
Replies: 24
Views: 14824

Re: No heat.

Try turning on Def. High. It is the red Def button above the on/off button on the hvac control panel.
Mine was not working and did this and have had heat on
Any setting ever since.
Worth a try and my save a trip back to Ford.

2013 ffe lease return.
by mdfocus
Sat Dec 24, 2016 11:57 am
Forum: Technical Discussions
Topic: Problem Moving from a Stop
Replies: 28
Views: 21609

Re: Problem Moving from a Stop

I have had this happen but only when in a hurry.
I make a habit to start the car then put on my seat belt.
Never had it happen then.
by mdfocus
Wed Sep 14, 2016 7:22 pm
Forum: General / Main Focus Electric Owners Forum
Topic: New FFE owner with a question
Replies: 9
Views: 3305

Re: New FFE owner with a question

I have a 2013. If doors are locked the rear latch button will not work. If I have the key fob with me it will open.
by mdfocus
Sun Jul 10, 2016 12:31 pm
Forum: Suggestions for Ford
Topic: Dear Ford...
Replies: 28
Views: 26602

Re: Dear Ford...

Please add option to turn off light ring. It is an attractive nuisance that invites trouble when parked outside overnight. I use a black garbage bag to cover it up. I tried a couple of layers of blue easy release painter's tape, which only dulls the glow. Totally agree--the ring light should be a c...

Go to advanced search