Search found 11 matches

Go to advanced search

by mattbrown
Fri Nov 20, 2020 6:27 pm
Forum: Technical Discussions
Topic: HV Battery Issues - Out of Warranty
Replies: 5
Views: 628

Re: HV Battery Issues - Out of Warranty

I had the exact same problem, and I did a write up on fixing mines recently. The leak causes an isolation fault rendering the pack useless until you go in remove the modules, clean all the leaked coolant out, remove heat exchangers (cooling plates) between each cell in each module, dry off the bus ...
by mattbrown
Fri Nov 20, 2020 6:05 pm
Forum: Technical Discussions
Topic: HV Battery Issues - Out of Warranty
Replies: 5
Views: 628

Re: HV Battery Issues - Out of Warranty

If you're out of warranty by only 4 months, call Ford yourself. I had a PT Cruiser that was just out of warranty. Power steering pump started leaking. Was going to be $1500 to repair. Called Chrysler, they said you pay $150, we'll pay the rest, and they did. Can't hurt. I have already contacted For...
by mattbrown
Thu Nov 19, 2020 12:15 pm
Forum: Technical Discussions
Topic: HV Battery Issues - Out of Warranty
Replies: 5
Views: 628

HV Battery Issues - Out of Warranty

An EV nightmare coming true Three weeks ago while my wife was driving our 2012 FFE, the Yellow Wrench symbol appeared. The car drove home fine and she parked it for the evening. In the morning I drove my car to work (30 kms) without warnings, plugged into the Level 2 charger at work and went about m...
by mattbrown
Fri Apr 22, 2016 6:05 am
Forum: General / Main Focus Electric Owners Forum
Topic: Field service Action 15B23
Replies: 22
Views: 14453

Re: Field service Action 15B23

Hi All, They most likely will not replace the battery for anything but cell failure. I had the same issue. Mine took 6 weeks and 4 days total time out of service. However, this was when the battery shield retrofit just came out, and some time was waiting for that. Hopefully your dealer orders the b...
by mattbrown
Wed Apr 20, 2016 12:14 pm
Forum: General / Main Focus Electric Owners Forum
Topic: Field service Action 15B23
Replies: 22
Views: 14453

Re: Field service Action 15B23

Hi All, This past Mon April 18th while driving 90 km/hr (I'm in Ontario, Canada eh!!!) on a side road I received my second SSN message. The first SSN message was back in Nov 2015 and due to a short in the cabin heater. I was able to come to a safe stop and get a tow from Ford Road Side Assistance to...
by mattbrown
Mon Oct 27, 2014 6:43 am
Forum: Technical Discussions
Topic: Missing "EV/Leaf" button in MFT
Replies: 22
Views: 15010

Re: Missing "EV/Leaf" button in MFT

jeffand wrote:If i remember correctly thier was a hardware up grade that required a module replacement. This only applies to some 2012 FFE. They will have to check the VIN number against the list of recalled vehicles.
Thanks for the info Jeff, I will make sure to ask the service tech about this.
by mattbrown
Wed Oct 22, 2014 7:11 pm
Forum: Technical Discussions
Topic: Missing "EV/Leaf" button in MFT
Replies: 22
Views: 15010

Re: Missing "EV/Leaf" button in MFT

Matt[/quote] Have you checked to see if you have 3.6?[/quote] Thanks for all the discussion, my car is running 3.6.? Which means it is up to date according to Sync My Ride. The dealer said they would continue to look into the problem, but I thought someone her may have run into this issue. I wonder ...
by mattbrown
Tue Oct 21, 2014 5:59 pm
Forum: Technical Discussions
Topic: Missing "EV/Leaf" button in MFT
Replies: 22
Views: 15010

Re: Missing "EV/Leaf" button in MFT

Hi Everyone, I finally got the car dealership to look into the missing EV/Leaf button. They didn't find anything on why it may be missing, but are going to continue looking for a solution. As seems to be usual with Ford dealers they really don't know much about the FFE. I had to show them the button...
by mattbrown
Mon Jul 28, 2014 5:38 am
Forum: Technical Discussions
Topic: Missing "EV/Leaf" button in MFT
Replies: 22
Views: 15010

Re: Missing "EV/Leaf" button in MFT

Thanks for the suggestion and I am contacting the local dealer. Does anyone know when the "EV/Leaf" button was added to MFT? Just so I can help the dealer track the timeline of the possible missing update.

Thanks,
by mattbrown
Sat Jul 26, 2014 12:32 pm
Forum: Technical Discussions
Topic: AC or heater - problem!
Replies: 15
Views: 13470

Re: AC or heater - problem!

I noticed a simular circumstance the other day. I had the car set to a go time and a temp of 65 F, when I got in the car it was very cool and blowing cold air. I unplugged the car and once started I noticed hot air coming from the vents. It didn't take long for me to realize my climate control was s...

Go to advanced search