Search found 24 matches

Go to advanced search

by Hokus
Sat Aug 18, 2018 12:28 pm
Forum: General / Main Focus Electric Owners Forum
Topic: Winter tires recommendations.
Replies: 15
Views: 9400

Re: Winter tires recommendations.

I have been doing a lot of research on tires since the OE suck for traction, even with a little rain. I just purchased a set of Nokian WR G3 All-Weather tires at Discount. They have to order them but supposedly they work well in all weather. There is a true difference in all-weather and all-season t...
by Hokus
Sat Aug 18, 2018 12:12 pm
Forum: Batteries and Charging Forum
Topic: What level 2 charger is everyone using these days?
Replies: 5
Views: 3085

Re: What level 2 charger is everyone using these days?

We also have a GE Wattstation. We had to replace it but I think that was more of the fault of the car we were plugging into it rather than the charger. The replacement has been working great for years.
by Hokus
Sat Aug 11, 2018 2:39 pm
Forum: News and Main Ford Focus Electric Forum
Topic: Tire Feedback
Replies: 5
Views: 5085

Re: Tire Feedback

Thank you for the reply. I drove it this morning after just a very light drizzle and it broke loose when I took off and then when I was trying to change lanes. I don't like the way it drives but I'm not the one who will be driving it daily. My wife hates it and I think probably more than I do. I ten...
by Hokus
Sun Aug 05, 2018 12:09 pm
Forum: News and Main Ford Focus Electric Forum
Topic: Tire Feedback
Replies: 5
Views: 5085

Re: Tire Feedback

So I see this is a pretty old topic but I am interested in any results. We recently bought a used 2013 FFE and hate the tires. Since this is a 5 year old vehicle with about 30K miles there is already some battery loss and I don't really want to add to the lost range by changing to the wrong times. I...
by Hokus
Mon Nov 17, 2014 7:12 pm
Forum: General / Main Focus Electric Owners Forum
Topic: Go time - not working?
Replies: 15
Views: 3739

Re: Go time - not working?

My wife has our Focus set at 85° every morning and 99% of the time the car is nice and warm when she gets in it. This morning she came back in the house and asked me which OTHER car she could take because she was worried that by the time she used the heat to warm/thaw the car she couldn't make it to...
by Hokus
Thu Sep 19, 2013 8:35 am
Forum: Technical Discussions
Topic: System Off to Preserve Battery
Replies: 56
Views: 18159

Re: System Off to Preserve Battery

I called them back last night to tell them that when I jumped the car and drove it to the dealer the drive batter was 100%. I don't see how it could have charged that battery and not the 12v, at least from a charger standpoint. It seems to me that would have had to be something internal. Oh well. I'...
by Hokus
Wed Sep 18, 2013 4:16 pm
Forum: Technical Discussions
Topic: System Off to Preserve Battery
Replies: 56
Views: 18159

Re: System Off to Preserve Battery

So they still have the car. They've been in contact with Ford Engineering running some tests. They've asked about whether I had the car in park, whether there was anything plugged into the USB port or any of the charging ports. I think I made a mistake by telling them that we have a GE Wattstation c...
by Hokus
Mon Sep 16, 2013 5:04 pm
Forum: Technical Discussions
Topic: System Off to Preserve Battery
Replies: 56
Views: 18159

Re: System Off to Preserve Battery

Update... so the dealer told me to call Ford Roadside Assistance. After explaining the problem they said I had an option to jump the vehicle or have it towed to the dealer. So I went for the "jump" option. I hooked my battery charger up to it and set it for a 50 amp start mode. I got in the car and ...
by Hokus
Sun Sep 15, 2013 11:15 am
Forum: Technical Discussions
Topic: System Off to Preserve Battery
Replies: 56
Views: 18159

Re: System Off to Preserve Battery

Well, it appears that you are correct. I hooked my battery charger up to it and it immediately started acting differently. The ring around the charge point came on and some of the lights on the dash came on. Now it wouldn't "start" the car but that may be due to the low voltage. There was a clicking...
by Hokus
Sun Sep 15, 2013 10:03 am
Forum: Technical Discussions
Topic: System Off to Preserve Battery
Replies: 56
Views: 18159

System Off to Preserve Battery

We had the software update done last Monday. Everything had been working fine. We've been enjoying some of the new features like the regen activating when you remove your foot from the accelerator pedal and having the OAT shown on the center screen now. We drove the car on Saturday and everything wa...

Go to advanced search